Windows-XP Apache+mysql+php インスト備忘録
2012/02/17(金) 10:36 はてブ情報 はてブに登録 はてブ数

Windows7 64bitにうまくインストできなかったmysql4.0.26-nt
Windows-XPにインストしてみた。
その他の環境のApache,Perl,phpのインストでバージョンすり合せがあったので備忘録。
  • Apache2.2 特に問題なし。マルチスレッド動作。
  • ActivePerl5.14.2 PPMでDBD-mysqlをインストール。今のところ問題なし。
  • PHP5.2.17 Thread safe. 
最初に5.3.1を入れたがphpMyAdmin2.11で以下のエラー
設定ファイルが作成されていないものと思われます。セットアップスクリプト を利用して設定ファイルを作成してください

エラー

MySQLのメッセージ:
#2054 - Connecting to 3.22, 3.23 & 4.0 servers is not supported
phpMyAdminのセットアップスクリプトをクリックしてサーバー追加してみたがだめ。
PHP5.2にしたら動いた。
phpMyAdminのセットアップスクリプトをもっといじればPHP5.3で動くかもしれませんが、とりあえずphpMyAdminが動けばいいのでPHPは5.2でいいことにしました。
  • phpMyAdmin 2.11.11.3
http://wiki.phpmyadmin.net/pma/Requirementsより
phpMyAdmin 3.x : MySQL 5.0.1 or newer
phpMyAdmin 2.x : MySQL 3.23.32 or newer (details)
ということで、mysqlが4.0なのでphpMyAdmin 2.11を使用
phpMyAdmin 2.x : PHP 4.2.0 or newer
ということでしたが、PHP5.2でないとだめでした。
http://www.php.net/manual/ja/migration53.phpではよくわかりませんでしたが。
ただし以下のようなメッセージが出ます。
お使いの PHP MySQL ライブラリのバージョン 5.0.51a が MySQL サーバのバージョン 4.0.26 と異なります。これは予期しない不具合を起こす可能性があります
うーん。下位互換なら特に問題なさそうだからほっておこう。

名前:  非公開コメント   

E-Mail(任意/非公開):
URL(任意):
  • TB-URL  http://www.cirlution.com/blog/adiary.cgi/032/tb/